L'anticamera del cestino

Raccolta differenziata di esperienze di dubbia utilità

Ubuntu 8.10: la webcam non funziona più

with 19 comments

Dopo l’installazione della versione 8.10 di Ubuntu la mia webcam Logitech Quickcam Messenger, che funzionava senza alcun intervento sulla 8.04,  ha smesso di funzionare correttamente con Skype. In particolare se attivo la webcam, Skype si chiude senza restituire alcun messaggio di errore.

E’ possibile risolvere aggirando il problema e creando un nuovo eseguibile per Skype:

$ sudo gedit /usr/local/bin/skype

Scrivere nel file il testo seguente e salvare.

#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

A questo punto non resta che rendere eseguibile il file:

$ sudo chmod 777 /usr/local/bin/skype

Lanciando l’eseguibile /usr/local/bin/skype la vostra webcam dovrebbe funzionare correttamente. A questo punto non resta che editare il menu Applicazioni di Ubuntu e modificare il comando assegnato al pulsante Skype con Sistema > Preferenze > Menu principale.

Invividuare il pulsante skype, premere proprietà e modificare il campo Comando con /usr/local/bin/skype

Written by Max-B

7 novembre 2008 a 11:59

Pubblicato su Linux

Tagged with , ,

19 Risposte

Subscribe to comments with RSS.

  1. Ho seguito le tue indicazioni ma non sembra aver ottenuto nessun effetto.
    Ho scritto nel file:
    #!/bin/bash
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
    proprio come lo avevi scritto tu ovvero /bash, a capo e il resto, ma andandolo poi a cercare nella cartella e cliccandoci sopra mi risponde errore…

    Andrea

    12 novembre 2008 at 19:45

  2. @Andrea
    Ho dimenticato di scrivere che devi rendere eseguibile il file.

    Dopo aver editato il file lancia il comando:

    $ sudo chmod 777 /usr/local/bin/skype

    Dovresti risolvere….
    ciao,
    Max

    maxborg

    13 novembre 2008 at 07:56

  3. Questa procedura risolve il problema della mia Creative Live Cam Notebook con skype.

    premetto che ho aggiornato v4l per risolvere il problema di base ma per skype ho fatto questa variazione alla tua proposta:

    1) gksu nautilus

    2) andare fino a /usr/bin

    3) rinominare skype in skype_or

    4) continuare la tua procedura variando la destinazione del nuovo eseguibile di skype poiché sarà posto sempre in /usr/bin

    5) dal terminale utente: sudo gedit /usr/bin/skype

    6)inserire il seguente testo:
    #!/bin/bash
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype_or

    7) dare i permessi: sudo chmod 777 /usr/bin/skype

    Finito!🙂

    Questa procedura evita di dover modificare i menù di tutti gli utenti del sistema. Insomma si evita di dover modificare i menù di gnome poiché l’eseguibile è sempre sotto /usr/bin

    Ciauuuu

    Papias

    15 novembre 2008 at 10:34

  4. Speriamo che aggiornino la versione di skype per linux!

    Papias

    15 novembre 2008 at 10:36

  5. qualche idea:

    rick@myBuntu:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
    ERROR: ld.so: object ‘/usr/lib/libv4l/v4l1compat.so’ from LD_PRELOAD cannot be preloaded: ignored.
    ^C
    rick@myBuntu:~$ ll /usr/lib/libv4l/v4l1compat.so
    -rw-r–r– 1 root root 5984 2008-11-27 14:53 /usr/lib/libv4l/v4l1compat.so

    Rick

    3 gennaio 2009 at 20:00

  6. Grasssie, funziona tutto ora!

    Andrea

    22 gennaio 2009 at 13:51

  7. maxborg sei un grande!!!Da quando sono passato l’anno scorso a Ubuntu 8.04 skype andava bene poi 2 settimane fa quando ho aggiornato il sistema alla versione 8.10 Intrepid addio webcam su skype ho provato a seguire aiuti dappertutto(perchè io non sono in grado di agire da solo purtroppo)ma nessuno è stato risolutivo come te!!!Complimenti!!!!Ah io ho un vecchio Laptop Asus L3400Tp con 256 Mb di ram e Webcam usb Trust WB-1400T(spero possa essere d’aiuto a qualcuno con la mia stessa webcam)e con il video condiviso a 32 me ne rimangono solo 224 di ram ma Ubuntu mi ha fatto innamorare…grazie a voi persone competenti e di grande levatura professionale…Grazie veramente è dovuto a te e alla comunità…anche perchè è assurdo vedere Laptop oggi con 4 Gb di memoria per gestire un sistema operativo come Vista…io non mi piego vivo in Scozia e comunico benissimo con questa macchina e con skype su ubuntu!!!Non molliamo c’è da divertirsi!
    P.S. un’altro problema che ho incontrato con la versione 8.10 intrepid è che Firefox non mi visualizza più bene nè YouTube nè il Java o il Flash per esempio non sò maxborg se mi puoi essere d’aiuto con la versione 8.04 il contatore sul nostro blog lo visualizzavo ora non più vedo solo il testo ma chi è connesso e da quale nazione non riesco più a vederlo il sito è il nostro blog http://quellidellatoscana.myblog.it/ grazie comunque per tutto!!!

    Tony@Scotland

    1 febbraio 2009 at 13:11

  8. sei semplicemente grande!!!!

    maurizio

    6 febbraio 2009 at 21:46

  9. Ciao a tutti,
    avete qualche notizia per la webcam creative live ultra su ubuntu 8.10?

    Non so più cosa fare.
    Camorama non la vede.
    Amsn e Skype nemmeno.

    Grazie.
    Yuri

    Yuri

    9 febbraio 2009 at 12:20

  10. azz, ma funge; e chi sei, mandrake? mille grazie, sono quelli come te che mandano avanti l’open source, e, in genere, la civiltà; ok ho esagerato, ma mica tanto…🙂

    johnj

    19 marzo 2009 at 23:34

  11. ah, per yoputube credo che basti mettere la versione vecchia di flash che trovi disinstallandolo da synaptic e poi cercando di vedere un filmato youtube e seguendo le istruzioni per il download; scarichi l’eseguibile e lo installi… con me ha funzionato😉

    johnj

    20 marzo 2009 at 00:05

  12. a me invece va in crash….ma perchè???
    ho una 1400 T

    luca

    19 maggio 2009 at 07:21

  13. mi dice questo….a volte crasha a volte si vede verde..

    luca@luca-desktop:~$ /usr/local/bin/skype
    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
    ALSA lib ../../../src/pcm/pcm.c:2165:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
    ALSA lib ../../../src/pcm/pcm.c:2165:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
    ALSA lib ../../../src/pcm/pcm.c:2165:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
    ALSA lib ../../../src/pcm/pcm.c:2165:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
    ALSA lib ../../../src/pcm/pcm.c:2165:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
    ALSA lib ../../../src/pcm/pcm.c:2165:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so
    Starting the process...
    Skype Xv: Xv ports available: 4
    Skype XShm: XShm support enabled
    Skype Xv: Using Xv port 131
     

    luca

    19 maggio 2009 at 07:22

  14. Sei un mito,grandissimo………………………….

    Salvo

    12 aprile 2010 at 18:16

  15. A distanza di anni e di 2 release, il tuo hack risolve ancora… Grazie mille!

    Angelo Rossi

    9 maggio 2010 at 14:37

  16. grazie del suggerimento ora la mia web funziona alla grande
    saluti efisio

    efisio

    30 ottobre 2010 at 10:21

  17. ho provato le procedure ma quando avvio il video mi restituisce questo:

    X Error, request 132, minor 18, error code 8 BadMatch (invalid parameter attributes)

    Daniele

    30 novembre 2010 at 00:34

  18. ho provato le procedure ma quando avvio il video mi restituisce questo:

    X Error, request 132, minor 18, error code 8 BadMatch (invalid parameter attributes

    c’è qualcos’altro che posso fare….???

    Grazie a tutti in anticipo🙂

    Daniele

    30 novembre 2010 at 00:36

  19. grazie per l’aiuto pur non sapendo che cosa ho fatto esattamente ho seguito la tua guida e adesso skype vede la cam…

    igor

    9 agosto 2011 at 13:30


Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: